Ri-Abilitare KNetworkManager all’avvio automatico in KDE4


Tweet

Di tanto in tanto, KNetworkManager, per motivi apparentemente sconosciuti, prende l’iniziativa e smarrisce quell’automatismo che gli permette di auto-proclamarsi titolare sin dal principio delle ostilità in KDE4.
Il significato equivalente alla folle introduzione è da ricondurre a quel misterioso evento che, mischiando le carte in tavola, colpisce improvvisamente KNetworkManager e non ne consente l’avvio automatico ad inizio sessione.

Nel dicembre del 2008, se ricordate (?!?!), avevamo trattato un’analoga circostanza che, a differenza dell’attuale, colpiva KDE3: in quel caso, modificando uno specifico file di configurazione, ne siamo usciti vincitori. «Hip hip hurra!»

Tuttavia, KDE4, in seguito alla sua evoluzione, resta impassibile dinnanzi alla procedura indicata in precedenza e la cura, che in KDE3 debellava il male, in questo caso risulta pressoché inutile a causa di alcuni cambiamenti.

Vediamo dunque come trattare il problema al fine di garantire l’autostart di KNetworkManager all’avvio di KDE4.

Aprire una console ed editare il file networkmanagementrc digitando:

kwrite ~/.kde4/share/config/networkmanagementrc

Il file, contiene le informazioni relative alle reti configurate che nel mio caso sono 2: Crismon’s Blog WiFi e Home WiFi.

[Connection_{xxxxxxx1-xxx1-xxx1-xxx1-xxxxxxxxxxx1}]
LastUsed=2010,5,3,17,31,19
Name=Home WiFi
Type=802-11-wireless
 
[Connection_{xxxxxxx2-xxx2-xxx2-xxx2-xxxxxxxxxxx2}]
LastUsed=2010,1,2,10,30,14
Name=Crismon's Blog WiFi
Type=802-11-wireless
 
[General]
Autostart=false
Connections={xxxxxxx1-xxx1-xxx1-xxx1-xxxxxxxxxxx1},{xxxxxxx2-xxx2-xxx2-xxx2-xxxxxxxxxxx2}

Come è possibile notare il file contiene una sezione denominata [General] all’interno della quale è presente il campo Autostart.

Se il valore del campo Autostart corrisponde a false, KNetworkManager, all’avvio di KDE4, riposerà in pace. In caso contrario, se settato su true, reagirà avviandosi automaticamente.

Modificare il valore del campo Autostart in true:

Autostart=true

Salvare il file e riavviare il server X.

Articoli Correlati

, ,

Segnala questo articolo: Queste icone linkano i siti di social bookmarking sui quali i lettori possono condividere e trovare nuove pagine web.
  • Facebook
  • del.icio.us
  • Digg
  • Reddit
  • StumbleUpon
  • Technorati
  • OKnotizie
  • Google Bookmarks
  • TwitThis
  • Upnews
  • Segnalo

  • Pingback: Tweets that mention Ri-Abilitare KNetworkManager all’avvio automatico in KDE4 « Crismon's Blog -- Topsy.com

  • enziosavio

    A me da circa una settimana non va pi?¹…..
    Ma non ho capito bene perch?¨ la connessione ?¨ attiva ma mi da un messaggio che ?¨ malconfigurato ……booooooooo
    Ho provato a riattivarlo adesso che ho letto ma mi ha ripetuto il messaggio……
    Ho gi?  provato a eliminare i File nei File nascosti di Kde4 e poi fare tutto da capo ma nisba…..
    Booooooooo

  • enziosavio

    Ecco cosa mi esce http://yfrog.com/7gschermata24p

  • http://www.crismonblog.org Maxwell

    @Crismon:fantastico…..non avevo tempo per cercare il problema, ma tu me lo hai brillantemente e gentilmente servito su un piatto d'argento!! :)

    @Eziosavio: sembra che knetworkmanager vada in conflitto con dbus…l'unico consiglio che ho per te ?¨ disinstallarlo, pulire tutti i file nascosti e installarlo nuovamente. il risultato non ?¨ garantito, ma se non l'hai fatto ?¨ una prova.

    ciao ciao
    Max

  • superlex

    Il mio era gi?  cos?¬, e infatti non ho mai avuto di questi problemi. Tuttavia, quando faccio una nuova connessione, appena la configuro non parte, poi riavvio la sessione e inizia a funzionare. boh!

  • enziosavio

    Aggiornato a Kde4.4.3 e ha ripreso a funzionare

  • http://www.crismonblog.org Crismon

    Capita anche a me, come dice Maxwell sembra un problema legato a DBUS…. Riavviando la sessione (logout e login) spesso e volentieri il problema sparisce.

  • http://www.crismonblog.org Crismon

    Eccoti servito :) Scherzi a parte ?¨ sempre un piacere!!

  • SleazyCriss

    Io avevo risolto eliminando i file di networkmanager e riavviando la sessione, questa ?¨ una soluzione meno drastica sicuramente!!